eXMP-SynqNet Features

.

eXMP-SynqNet Features

  • An Intel 366 MHz Celeron CPU running VxWorks®, as well as a high-performance Analog Devices 32-bit floating point SHARC DSP. Use of VxWorks with XMP-Series motion controllers is described in a separate MPI/XMP VxWorks Release Note, available from Motion Engineering; more detailed VxWorks information is available from Wind River Systems, Inc. (http://www.wrs.com).

  • Supports up to 32 axes of SynqNet motor control.

  • Supports CAN interface for integrated I/O programming.

  • Supports SynqNet via 10/100 MBit Ethernet using TCP/IP.

  • Provides all of the XMP’s advanced capabilities, including flexible control algorithms, and support for a variety of position feedback devices.

  • The embedded CPU communicates with the DSP via direct memory reads and writes over a 32-bit PCI bus.

  • Supports applications authored with the MPI or MPX.

  • Supports the use of MEI’s Motion Console and Motion Scope development utilities to configure and debug all axes.

Legal Notice | Tech Email | Feedback
Copyright © 2004 Motion Engineering


Hardware

.

Select a section below.


CAN Connector

.

CAN Connector

Pin | Signal | Description
1 | (unused) | Reserved
2 | CAN_L | CAN_L bus line dominant low
3 | CAN_GND | CAN Ground
4 | – | Reserved
5 | (CAN_SHLD) | Optional CAN Shield
6 | CAN_GND | CAN Ground
7 | CAN_H | CAN_H bus line dominant high
8 | – | Reserved
9 | CAN_V+ | CAN external supply*
* Used with opto-isolation mode


Power Connector

.

Power Connector

Pin | Signal
1 | +24 VDC
2 | 24 VDC Common


eXMP-SynqNet Hardware

.

Specifications
 Hardware and Electrical Requirements
Enclosure Dimensions
Architecture
Features

Pinouts
 Connector Pinouts
Power
Ethernet RJ-45
SynqNet RJ-45
User I/O
CAN
Com 2
Com 1
Com 1-4

LEDs
Ethernet
CAN
SynqNet

Documentation
Linux
 Quick Start Guide
Board Support Package Guide
Linux Release Note

VxWorks
 Quick Start Guide
VxWorks Release Note

Installing a SynqNet-eXMP Motion System
General Controller I/O Specifications
Connect eXMP User I/O

IMPORTANT
Temperature Monitoring
Introduction
Using the MPI to Check Temperature

Problems Connecting?

For the eXMP to communicate with devices on a TCP/IP network, the subnets on the eXMP and host network must match. The eXMP is pre-configured with the IP address 192.168.1.74, which can be used to access it during the initial configuration. During the initial configuration, it is necessary to temporarily change the IP address of your host computer to one in the same subnet as the eXMP. For example, set the IP address of your host computer to 192.168.1.1. If your local subnet is anything other than 192.168.1.XXX, you will not be able to communicate with the eXMP. Another option is to use a serial cable and console adapter to change the subnet and/or IP address of the eXMP to match your host computer. The Quick Start Guides contains step-by-step instructions on changing the eXMP's IP address.


eXMP Architecture

.

eXMP Architecture

Introduction | Dual-processor Network Architecture | Flexible Development Environment

Introduction

In a standard, bus-based XMP, the DSP and Motion Block subsystems reside in the host PC. As a distributed controller, the eXMP pairs a 366 MHz CPU with the SHARC DSP in a completely autonomous, standalone package.

Since it executes motion programs independent of a host computer, the eXMP is ideal for a variety of high-performance motion control applications, including semiconductor manufacturing, electronic assembly, and robotics.

Figure 1. Low-level communication between the host and eXMP-SynqNet.

Figure 2. High-level communication between the host and eXMP-SynqNet.

Dual-processor Network Architecture

The eXMP controller combines a powerful 366 MHz Intel Celeron microprocessor with a 32-bit floating point SHARC DSP from Analog Devices for autonomous, network-aware motion control. Execution of user programs and communication with other network devices occur on the microprocessor, while the SHARC DSP closes the position loop and handles all real-time servo calculations.

Communication with the higher-level control systems, other network hosts, and popular I/O networks is possible through the on-board 100 MBit Ethernet.

Flexible Development Environment

Running VxWorks, the eXMP provides a highly programmable, highly flexible software development environment. Microsoft Visual Studio or the Wind River Tornado development environment provides a simple way to cross-compile your motion application. The eXMP software provides a full Board Support Package (BSP) that makes it easy to connect to the system across a TCP/IP network.

With full TCP/IP support, MEI’s Windows-based tools can also communicate with the eXMP across a network with the server.exe utility program. Both Motion Console and Motion Scope can be used to configure, tune and troubleshoot problems with the eXMP standalone controller.

User programs can be stored locally in flash memory, or executed in real time across the network from a remote host.


Com 1 Connector

.

Com 1 Connector

Pin | Signal
1 | CD1
2 | RXD1
3 | TXD1
4 | DTR1
5 | GND1
6 | DSR1
7 | RTS1
8 | CTS1
9 | RIN1


Com 1-4 Connector

.

Com 1-4 Connector

Pin | Signal
1 | GND1
2 | RXD1
3 | GND2
4 | RXD2
5 | GND3

Pin | Signal
6 | RXD3
7 | TXD4
8 | GND4
9 | TXD1
10 | GND5

Pin | Signal
11 | TXD2
12 | GND6
13 | TXD3
14 | GND7
15 | RXD4


Com 2 Connector

.

Com 2 Connector

Pin | Signal
1 | CD2
2 | RXD2
3 | TXD2
4 | DTR2
5 | GND2
6 | DSR2
7 | RTS2
8 | CTS2
9 | RIN2


eXMP Enclosure Dimensions

.

eXMP Enclosure Dimensions


Ethernet RJ-45 Connector

.

Ethernet RJ-45 Connector

Pin | Signal
1 | TD+
2 | TD-
3 | RD+
4 |
5 |
6 | RD-
7 |
8 |


eXMP-SynqNet Controllers: Hardware and Electrical Requirements

.

eXMP-SynqNet Controllers:
Hardware and Electrical Requirements

Environmental

Description | Operating Range
Temperature | 0-50 Deg. C
Humidity | 20-80% RH (no condensation)

Power

Power requirements for the eXMP-SynqNet are shown in the chart below.

Voltage
Operating Range
24VDC +/- 10%
Current
Peak | 2.4 Amps
Typical | 2.0 Amps

Memory

Type | Capacity
RAM | 32MB
Compact Flash | 32MB


User I/O Connector

.

User I/O Connector

Pin | Signal | Signal | Pin
1 | Gnd | Gnd | 26
2 | OPTOA | OPTOA_Rtn | 27
3 | OPTOB | OPTOB_Rtn | 28
4 | OPTOC | OPTOC_Rtn | 29
5 | OPTOD | OPTOD_Rtn | 30
6 | OPTOE | OPTOE_Rtn | 31
7 | OPTOF | OPTOF_Rtn | 32
8 | XESTOP | XESTOP_Rtn | 33
9 | Not Connected | Not Connected | 34
10 | Not Connected | Not Connected | 35
11 | Not Connected | Not Connected | 36
12 | Not Connected | Not Connected | 37
13 | Gnd | Gnd | 38
14 | Reserved | Reserved | 39
15 | Reserved | Reserved | 40
16 | Reserved | Reserved | 41
17 | Reserved | Reserved | 42
18 | Reserved | Reserved | 43
19 | Reserved | Reserved | 44
20 | Reserved | Reserved | 45
21 | Reserved | Reserved | 46
22 | Not Connected | Not Connected | 47
23 | Not Connected | Not Connected | 48
24 | Not Connected | Not Connected | 49
25 | Gnd | Gnd | 50

Cable Accessory

MEI offers the following cable accessory:
C001-0018
CBL-50 VHDCI D-SUB
Interface Cable


CAN LEDs

.

CAN LEDs

The CAN port has two LEDs: CAN1 and CAN2. See the table below for the meaning of each LED and its state.

LED State Table: CAN
CAN1 | CAN2 | Code Executing | State
OFF | OFF | None | No power / No bootloader present
BLINK | ON | Bootloader | No firmware (waiting for firmware)
OFF | ON | Bootloader | Programming firmware
ON | ON | Firmware | No Configuration
ON | OFF |  | Bootloader present with valid firmware
ON | Fast Blinking (0.25/sec) | Firmware | CAN Bus Error
ON | Slow Blinking (1/sec) | Firmware | CAN Operational


Ethernet LEDs

.

Ethernet LEDs

The Ethernet port has two LEDs: Link/Act and 10/100. See the table below for the meaning of each LED and its state.

LED State Table: Ethernet
LED | Meaning | State
Link/Act | Link Activity | ON = link active
 |  | BLINK = network activity
 |  | OFF = link inactive
10/100 | Baud Rate / Network Speed | ON = 100Mb
 |  | OFF = 10Mb


SynqNet LEDs

.

SynqNet LEDs

LED State Table: SynqNet
LED | Port | Meaning | Controlled by | State
LED1 | OUT | Link Activity | PHY | ON = link active
 |  |  |  | OFF = link inactive
LED2 | OUT | Network Activity | MAC | ON = Tx and Rx active (cyclic phase)
 |  |  |  | BLINK = Tx only active (discovery phase)
 |  |  |  | OFF = Idle (shutdown phase)
LED3 | IN | Link Activity | PHY | ON = link active
 |  |  |  | OFF = link inactive
 |  |  |  | ON = Tx
LED4 | IN | Network Activity | MAC | ON = Tx and Rx active (cyclic phase)
 |  |  |  | BLINK = Tx only active (discovery phase)
 |  |  |  | OFF = idle (shutdown phase)


SynqNet RJ-45 Connector

.

SynqNet RJ-45 Connector

Pin | In | Out
 | Standard pinout (NIC=MDI) | Crossover pinout (HUB=MDI-X)
1 | Transmit + | Receive +
2 | Transmit - | Receive -
3 | Receive + | Transmit +
4 | UUPI + | UUPI +
5 | UUPI - | UUPI -
6 | Receive - | Transmit -
7 | UUP2 + | UUP2 +
8 | UUP2 - | UUP2 -
- | SHLD | SHLD

UUP1 and UUP2 are "unused pair" 1 and 2. When using a standard CAT5 cable, these pairs are connected to the two unused pairs in the 4 pair (8 wire) cable.

NOTE: Standard CAT5 design practice is to terminate these pairs on the PCB to reduce noise. When using a 2 pair cable, these pins are left unconnected in the cable.

Cable Accessory

MEI offers the following cable accessory:
- C007-0001 (1.2m)
- C007-0002 (3m)
- C007-0003 (10m)


DSP Hardware Home

.

DSP Manuals
 Installation Manual
DSP Pro Manual
Application Notes
 OptoCon Release Note

Pinouts
 CPCI
LC
PCI
PCX
STD
V6U
104
104X

Data Sheets
 PCI / DSP
PCX / DSP
VME / DSP
104 /DSP
104X / DSP
LC / DSP
OptoCon


DSP-CPCI: Rear I/O Bus J4

.

DSP-CPCI: Rear I/O Bus J4

For Header Locations:

  • CPCI

Pin | E | D | C | B | A
25 | +5V | Encoder Index(4)– | Encoder Index(4)+ | Encoder Index(3)– | Encoder Index(3)+
24 | Gnd | Encoder B(4)– | Encoder B(4)+ | Encoder A(4)– | Encoder A(4)+
23 | Encoder Index(5)+ | Encoder B(5)– | Encoder B(5)+ | Encoder A(5)– | Encoder A(5)+
22 | Encoder Index(5)– | Encoder B(6)– | Encoder B(6)+ | Encoder A(6))– | Encoder A(6)+
21 | Reserved | Encoder B(7)– | Encoder B(7)+ | Encoder A(7)– | Encoder A(7)+
20 | Reserved | Encoder Index(7)– | Encoder Index(7)+ | Encoder Index(6)– | Encoder Index(6)+
19 | Negative Limit(0) | Positive Limit(0) | Home Input(0) | Amp Fault(0) | Amp Enable(0)
18 | Reserved | In Position(1) | User I/O PC0 | Reserved | In Position(0)
17 | Negative Limit(1) | Positive Limit(1) | Home Input(1) | Amp Fault(1) | Amp Enable(1)
16 | Negative Limit(2) | Positive Limit(2) | Home Input(2) | Amp Fault(2) | Amp Enable(2)
15 | Reserved | In Position(3) | User I/O PCI | Reserved | In Position(2)
14 | Key Area | Key Area | Key Area | Key Area | Key Area
13
12
11 | Negative Limit(3) | Positive Limit(3) | Home Input(3) | Amp Fault(3) | Amp Enable(3)
10 | Negative Limit(4) | Positive Limit(4) | Home Input(5) | Amp Fault(4) | Amp Enable(4)
9 | Reserved | In Position(5) | User I/O PC2 | Reserved | In Position(4)
8 | Negative Limit(5) | Positive Limit(5) | Home Input(5) | Amp Fault(5) | Amp Enable(5)
7 | Negative Limit(6) | Positive Limit(6) | Home Input(6) | Amp Fault(6) | Amp Enable(6)
6 | Reserved | In Position(7) | User I/O PC3 | Reserved | In Position(6)
5 | Negative Limit(7) | Positive Limit(7) | Home Input(7) | Amp Fault(7) | Amp Enable(7)
4 | User I/O PC4 | User I/O PA3 | User I/O PA2 | User I/O PA1 | User I/O PA0
3 | User I/O PC5 | User I/O PA7 | User I/O PA6 | User I/O PA5 | User I/O PA4
2 | User I/O PC6 or DSP Interrupt | User I/O PB3 | User I/O PB2 | User I/O PB1 | User I/O PB0
1 | User I/O PC7 or PC Interrupt | User I/O PB7 | User I/O PB6 | User I/O PB5 | User I/O PB4
Pin | E | D | C | B | A


DSP-CPCI: Rear I/O Bus J5

.

DSP-CPCI: Rear I/O Bus J5

For Header Locations:

  • CPCI

* - Column F is the gold-plated grounding strip on the outside edge of the shroud. F1-F22 are grounds.

Pin | E | D | C | B | A
22 | Analog in 3 | Analog in 2 | Analog Gnd | Analog in 1 | Analog in 0
21 | Analog in 7 | Analog in 6 | Analog Gnd | Analog in 5 | Analog in 4
20 | Reserved | Reserved | –12V | Analog Out Ref(0) | +/- 10V Analog Out(0)
19 | Reserved | Reserved | Analog Gnd | Analog Out Ref(1) | +/- 10V Analog Out(1)
18 | Reserved | Reserved | +12V | Analog Out Ref(2) | +/- 10V Analog Out(2)
17 | Reserved | Reserved | Analog Gnd | Analog Out Ref(3) | +/- 10V Analog Out(3)
16 | Reserved | Reserved | Reserved | Analog Out Ref(4) | +/- 10V Analog Out(4)
15 | Reserved | Reserved | Reserved | Analog Out Ref(5) | +/- 10V Analog Out(5)
14 | Reserved | Reserved | +5V | Analog Out Ref(6) | +/- 10V Analog Out(6)
13 | Reserved | Reserved | Gnd | Analog Out Ref(7) | +/- 10V Analog Out(7)
12 | Out 2 | Out 1 | Out 0 | Gate 0 | Clock 0
11 | Direction(7)+ | Step Pulse(0)– | Step Pulse(0)+ | Direction(0)– | Direction(0)+
10 | Direction(7)– | Step Pulse(1)– | Step Pulse(1)+ | Direction(1)– | Direction(1)+
9 | Step Pulse(7)+ | Step Pulse(2)– | Step Pulse(2)+ | Direction(2)– | Direction(2)+
8 | Step Pulse(7)– | Step Pulse(3)– | Step Pulse(3)+ | Direction(3)– | Direction(3)+
7 | Reserved | Step Pulse(4)– | Step Pulse(4)+ | Direction(4)– | Direction(4)+
6 | Encoder Index(0)+ | Step Pulse(5)– | Step Pulse(5)+ | Direction(5)– | Direction(5)+
5 | Encoder Index(0)– | Step Pulse(6)– | Step Pulse(6)+ | Direction(6)– | Direction(6)+
4 | Encoder Index(1)+ | Encoder B(0)– | Encoder B(0)+ | Encoder A(0)– | Encoder A(0)+
3 | Encoder Index(1)– | Encoder B(1)– | Encoder B(1)+ | Encoder A(1)– | Encoder A(1)+
2 | Encoder Index(2)+ | Encoder B(2)– | Encoder B(2)+ | Encoder A(2)– | Encoder A(2)+
1 | Encoder Index(2)– | Encoder B(3)– | Encoder B(3)+ | Encoder A(3)– | Encoder A(3)+
Pin | E | D | C | B | A


DSP Dedicated I/O Axes 0-3: P2

.

DSP Dedicated I/O Axes 0-3: P2

For Header Locations:

  • PCX
  • CPCI
  • STD
  • 104X
  • V6U

There are 6 Dedicated I/O signals for each axis of the controller: 4 inputs and 2 outputs. All even pins are grounds.

Inputs | Positive Limit Negative Limit Home Amplifier Fault
Outputs | In Position Amplifier Enable

Dedicated I/O Connections: 50-pin box headers
Pin | Signal | P2 Axis
1 | In-Position Out | 3
3 | Amp Enable Out | 3
5 | In-Position Out | 2
7 | Amp Enable Out | 2
9 | In-Position Out | 1
11 | Amp Enable Out | 1
13 | In-Position Out | 0
15 | Amp Enable Out | 0
17 | Amp Fault Input | 3
19 | Home Input | 3
21 | NEG Limit Input | 3
23 | POS Limit Input | 3
25 | Amp Fault Input | 2
27 | Home Input | 2
29 | NEG Limit Input | 2
31 | POS Limit Input | 2
33 | Amp Fault Input | 1
35 | Home Input | 1
37 | NEG Limit Input | 1
39 | POS Limit Input | 1
41 | Amp Fault Input | 0
43 | Home Input | 0
45 | NEG Limit Input | 0
47 | POS Limit Input | 0
49 | + 5V |

NOTE: All even pins are grounds.


DSP Dedicated I/O Axes 4-7: P3

.

DSP Dedicated I/O Axes 4-7: P3

For Header Locations:

  • PCX
  • CPCI
  • STD
  • 104X
  • V6U

There are 6 Dedicated I/O signals for each axis of the controller: 4 inputs and 2 outputs. All even pins are grounds.

Inputs | Positive Limit Negative Limit Home Amplifier Fault
Outputs | In Position Amplifier Enable

The even-numbered pins are grounds, and pin 49 is +5V.

Dedicated I/O Connections: 50-pin box headers
Pin | Signal | P3 Axis
1 | In-Position Out | 7
3 | Amp Enable Out | 7
5 | In-Position Out | 6
7 | Amp Enable Out | 6
9 | In-Position Out | 5
11 | Amp Enable Out | 5
13 | In-Position Out | 4
15 | Amp Enable Out | 4
17 | Amp Fault Input | 7
19 | Home Input | 7
21 | NEG Limit Input | 7
23 | POS Limit Input | 7
25 | Amp Fault Input | 6
27 | Home Input | 6
29 | NEG Limit Input | 6
31 | POS Limit Input | 6
33 | Amp Fault Input | 5
35 | Home Input | 5
37 | NEG Limit Input | 5
39 | POS Limit Input | 5
41 | Amp Fault Input | 4
43 | Home Input | 4
45 | NEG Limit Input | 4
47 | POS Limit Input | 4
49 | + 5V |

NOTE: All even pins are grounds.


DSP-104

.

DSP-104

Pinouts
User I/O and Dedicated I/O Axes 0-3


DSP-CPCI

.

DSP-CPCI

Pinouts
User I/O

Dedicated I/O Axes 0-3
Dedicated I/O Axes 4-7

Motor Axes 0-7

Analog Inputs (8)

Rear I/O J4
Rear I/O J5


DSP-LC

.

DSP-LC

Pinouts
User I/O and Dedicated I/O Axes 0-3


DSP-PCI

.

DSP-PCI

Pinouts
Motor Axes 0-4

User I/O


DSP-PCX

.

DSP-PCX

Pinouts
User I/O

Dedicated I/O Axes 0-3
Dedicated I/O Axes 4-7

Motor Axes 0-7

Analog Inputs (8)


DSP-STD and DSP-104X

.

DSP-STD
DSP-104X

Pinouts
User I/O

Dedicated I/O Axes 0-3
Dedicated I/O Axes 4-7

Motor Axes 0-7

Analog Inputs (8)


DSP-V6U

.

DSP-V6U

Pinouts
User I/O

Dedicated I/O Axes 0-3
Dedicated I/O Axes 4-7

Motor Axes 0-7

Analog Inputs (8)


DSP Pinouts: User I/O and Motor Axes 0-3

.

DSP Pinouts: User I/O and Motor Axes 0-3

Top Cable: (red)
User I/O
Motor Axes 0-1

Bottom Cable: (blue)
User I/O
Motor Axes 2-3

For Header Locations:

  • 104
  • LC

Motor Axes Connections— Top Cable: User I/O and Motor Axes 0-1 (red) 50-pins
Pin | Signal
1 | +5V
3 | Encoder A(0) +
5 | Encoder A(0) –
7 | Encoder B(0) +
9 | Encoder B(0) –
11 | Encoder Index(0) +
13 | Encoder Index(0) –
15 | +/– 10V Analog Out(0)
17 | Gnd
19 | Step Pulse(0)+
21 | Step Pulse(0) –
23 | Direction(0)+
25 | Direction(0) –
27 | Positive Limit(0)
29 | Positive Limit(0)
31 | Home Input(0)
33 | Amp Fault(0)
35 | Amp Enable(0)
37 | In Position(0)
39 | User I/O PA0
41 | User I/O PA1
43 | User I/O PA2
45 | User I/O PC0
47 | User I/O PC1
49 | Gnd

Signal | Pin
+5V | 2
Encoder A(1) + | 4
Encoder A(1) – | 6
Encoder B(1) + | 8
Encoder B(1) – | 10
Encoder Index(1) + | 12
Encoder Index(1) – | 14
+/– 10V Analog Out(1) | 16
Gnd | 18
Step Pulse(1)+ | 20
Step Pulse(1) – | 22
Direction(1)+ | 24
Direction(1) – | 26
Positive Limit(1) | 28
Positive Limit(1) | 30
Home Input(1) | 32
Amp Fault(1) | 34
Amp Enable(1) | 36
In Position(1) | 38
User I/O PA3 | 40
User I/O PA4 | 42
User I/O PA5 | 44
User I/O PC2 | 46
User I/O PC3 | 48
Gnd | 50

Motor Axes Connections— Bottom Cable: User I/O and Motor Axes 2-3 (blue) 50-pins
Pin | Signal
1 | +5V
3 | Encoder A(2) +
5 | Encoder A(2) –
7 | Encoder B(2) +
9 | Encoder B(2) –
11 | Encoder Index(2) +
13 | Encoder Index(2) –
15 | +/– 10V Analog Out(2)
17 | Gnd
19 | Step Pulse(2)+
21 | Step Pulse(2) –
23 | Direction(2)+
25 | Direction(2) –
27 | Positive Limit(2)
29 | Positive Limit(2)
31 | Home Input(2)
33 | Amp Fault(2)
35 | Amp Enable(2)
37 | In Position(2)
39 | User I/O PB0
41 | User I/O PB1
43 | User I/O PB2
45 | User I/O PC4
47 | User I/O PC5
49 | Gnd

Signal | Pin
+5V | 2
Encoder A(3) + | 4
Encoder A(3) – | 6
Encoder B(3) + | 8
Encoder B(3) – | 10
Encoder Index(3) + | 12
Encoder Index(3) – | 14
+/– 10V Analog Out(3) | 16
Gnd | 18
Step Pulse(3)+ | 20
Step Pulse(3) – | 22
Direction(3)+ | 24
Direction(3) – | 26
Positive Limit(3) | 28
Positive Limit(3) | 30
Home Input(3) | 32
Amp Fault(3) | 34
Amp Enable(3) | 36
In Position(3) | 38
User I/O PB3 | 40
User I/O PB4 | 42
User I/O PB5 | 44
User I/O PC6 or DSP Interrrupt | 46
User I/O PC7 or PC Interrrupt | 48
Gnd | 50


DSP Analog Inputs: P8

.

DSP Analog Inputs: P8

For Header Locations:

  • PCX
  • CPCI
  • STD
  • 104X
  • V6U

Two motors of the same type can be connected to each motor header.

Analog Input Connections: 20-pin box headers
Pin | Signal | Signal | Pin
1 | Gnd | Analog Gnd | 2
3 | Clock 0 | Analog in 0 | 4
5 | –12V | Analog in 1 | 6
7 | +12V | Analog in 2 | 8
9 | +5V | Analog in 3 | 10
11 | Gate 0 | Analog in 4 | 12
13 | Out 0 | Analog in 5 | 14
15 | Out 1 | Analog in 6 | 16
17 | Out 2 | Analog in 7 | 18
19 | Gnd | Analog Gnd | 20


DSP Pinouts: Motor Axes 0-3

.

DSP Pinouts: Motor Axes 0-3

Mating Connector:
Honda HDRA - E68MA1

Mating Shell:
Honda HDRA - E68LGKPE

For Header Locations:

  • PCI

Use the STC-136 for easy prototyping with the motor I/O connectors of the DSP-PCI.

Use cable MEI P/N C001-0011 (1 Meter)
C001-0012 (2 Meter)
C001-0013 (3 Meter) to connect to an STC-136 ( breakout board).

Motor Axes Connections— Motor Axes 0-1, 68-pins

Pin | Signal
1 | Analog 0+
2 | Analog 1+
3 | Gnd
4 | Enc0_A+
5 | Enc0_B+
6 | Enc0_I+
7 | Home0_IN
8 | Pos_Lim0_IN
9 | Neg_Lim0_IN
10 | Command_0+
11 | Reserved
12 | Amp_Flt0_In
13 | Amp_En0_C
14 | Reserved
15 | Step0+
16 | Dir0+
17 | In_Pos0+
18 | Enc1_A+
19 | Enc1_B+
20 | Enc1_I+
21 | Home1_IN
22 | Pos_Lim1_IN
23 | Neg_Lim1_IN
24 | Command_1+
25 | Reserved
26 | Amp_Flt1_IN
27 | Amp_En1_C
28 | Gnd
29 | Step1+
30 | Dir1+
31 | In_Pos1+
32 | Gnd
33 | Analog_4+
34 | Analog_5+

Signal | Pin
AGnd | 35
AGnd | 36
Gnd | 37
Enc0_A– | 38
Enc0_B– | 39
Enc0_I– | 40
5V_OUT | 41
Gnd_OUT | 42
Mech0_Rtn | 43
Command_0– | 44
Reserved | 45
Amp_Flt0_Rtn | 46
Amp_En0_E | 47
Reserved | 48
Step0- | 49
Dir0- | 50
In_Pos0– | 51
Enc1_A– | 52
Enc1_B– | 53
Enc1_I– | 54
5V_OUT | 55
Gnd_OUT | 56
Mech1_Rtn | 57
Command_1– | 58
Reserved | 59
Amp_Flt1_Rtn | 60
Amp_En1_E | 61
Gnd | 62
Step1– | 63
Dir1– | 64
In_Pos1– | 65
Gnd | 66
AGnd | 67
AGnd | 68

Motor Axes Connections— Motor Axes 2-3, 68-pins

Pin | Signal
1 | Analog 6+
2 | Analog 7+
3 | Gnd
4 | Enc2_A+
5 | Enc2_B+
6 | Enc2_I+
7 | Home2_IN
8 | Pos_Lim2_IN
9 | Neg_Lim2_IN
10 | Command_2+
11 | Reserved
12 | Amp_Flt2_In
13 | Amp_En2_C
14 | Reserved
15 | Step2+
16 | Dir2+
17 | In_Pos2+
18 | Enc3_A+
19 | Enc3_B+
20 | Enc3_I+
21 | Home3_IN
22 | Pos_Lim3_IN
23 | Neg_Lim3_IN
24 | Command_3+
25 | Reserved
26 | Amp_Flt3_IN
27 | Amp_En3_C
28 | Gnd
29 | Step3+
30 | Dir3+
31 | In_Pos3+
32 | Gnd
33 | Analog_2+
34 | Analog_3+

Signal | Pin
AGnd | 35
AGnd | 36
Gnd | 37
Enc2_A– | 38
Enc2_B– | 39
Enc2_I– | 40
5V_OUT | 41
Gnd_OUT | 42
Mech2_Rtn | 43
Command_2– | 44
Reserved | 45
Amp_Flt2_Rtn | 46
Amp_En2_E | 47
Reserved | 48
Step2- | 49
Dir2- | 50
In_Pos2– | 51
Enc3_A– | 52
Enc3_B– | 53
Enc3_I– | 54
5V_OUT | 55
Gnd_OUT | 56
Mech3_Rtn | 57
Command_3– | 58
Reserved | 59
Amp_Flt3_Rtn | 60
Amp_En3_E | 61
Gnd | 62
Step3– | 63
Dir3– | 64
In_Pos3– | 65
Gnd | 66
AGnd | 67
AGnd | 68


DSP Pinouts: Motor Axes 0-7

.

DSP Pinouts: Motor Axes 0-7

Motor Axes 0, 1: P6
Motor Axes 2, 3: P7
Motor Axes 4, 5: P4
Motor Axes 6, 7: P5

For Header Locations:

  • PCX
  • CPCI
  • STD
  • 104X
  • V6U

Two motors of the same type can be connected to each motor header.
1st Axis: Pins 1-13
2nd Axis: Pins 14-26

Motor Axes Connections: 26-pin box headers

1st Axis
Pin | Signal | Signal | Pin
1 | Gnd | 5V | 2
3 | Encoder A + | Encoder A – | 4
5 | Encoder B + | Encoder B – | 6
7 | Encoder Index + | Encoder Index – | 8
9 | +/- 10V Analog Out | Step Pulse + | 10
11 | Step Pulse – | Step Direction + | 12
13 | Step Direction – |  |

2nd Axis
Pin | Signal | Signal | Pin
 |  | GND | 14
15 | 5V | Encoder A + | 16
17 | Encoder A – | Encoder B + | 18
19 | Encoder B – | Encoder Index + | 20
21 | Encoder Index – | +/- 10V Analog Out | 22
23 | Step Pulse + | Step Pulse – | 24
25 | Step Direction + | Step Direction – | 26


DSP User I/O: P1

.

DSP User I/O: P1

For Header Locations:

  • PCX
  • CPCI
  • STD
  • 104X
  • V6U

The PCX, CPCI, STD, 104X, and V6U Series Controllers support 24 or 44-bits of general purpose I/O. These signals can be configured as inputs or outputs in groups of 8.

Dedicated I/O for axes 4-7 is available for User I/O on PCX, CPCI, STD, and V6U controllers with four or less axes. If an 8-bit port with Home sensor signals is configured as an output port, only 6 of the 8 signals can be used. For the PCX, CPCI, STD, and V6U the Home Sensor inputs are not available for User I/O. The following diagram shows the configuration of the 72 I/O lines for the PCX, CPCI, STD, and V6U.

Each I/O Port (A,B,C) can be defined as inputs or outputs.

User I/O Connections: 50-pin Opto-22 compatible header
Pin | Signal
1 | I/O Line C-7 or PC Interrupt
3 | I/O Line C-6 or DSP Interrupt
5 | I/O Line C-5
7 | I/O Line C-4
9 | I/O Line C-3
11 | I/O Line C-2
13 | I/O Line C-1
15 | I/O Line C-0
17 | I/O Line B-7
19 | I/O Line B-6
21 | I/O Line B-5
23 | I/O Line B-4
25 | I/O Line B-3
27 | I/O Line B-2
29 | I/O Line B-1
31 | I/O Line B-0
33 | I/O Line A-7
35 | I/O Line A-6
37 | I/O Line A-5
39 | I/O Line A-4
41 | I/O Line A-3
43 | I/O Line A-2
45 | I/O Line A-1
47 | I/O Line A-0
49 | + 5V

NOTE: All even pins are grounds.


DSP User I/O

.

DSP User I/O

Mating Connector:
Honda HDR - E50MG1

Mating Shell:
Honda HDR - E50LPA

For Header Locations:

  • PCI

The User I/O connector for the DSP-PCI is used with the STC-D50.

User I/O Connections — 50 I/O

Pin | Signal
1 | UserIO_A0
2 | UserIO_A1
3 | UserIO_A2
4 | UserIO_A3
5 | UserIO_A4
6 | UserIO_A5
7 | UserIO_A6
8 | UserIO_A7
9 | UserIO_B0
10 | UserIO_B1
11 | UserIO_B2
12 | UserIO_B3
13 | UserIO_B4
14 | UserIO_B5
15 | UserIO_B6
16 | UserIO_B7
17 | UserIO_C0
18 | UserIO_C1
19 | UserIO_C2
20 | UserIO_C3
21 | UserIO_C4
22 | UserIO_C5
23 | UserIO_C6
24 | UserIO_C7
25 | 5V

Signal | Pin
UserIO_A0_Rtn | 26
UserIO_A1_Rtn | 27
UserIO_A2_Rtn | 28
UserIO_A3_Rtn | 29
UserIO_A4_Rtn | 30
UserIO_A5_Rtn | 31
UserIO_A6_Rtn | 32
UserIO_A7_Rtn | 33
UserIO_B0_Rtn | 34
UserIO_B1_Rtn | 35
UserIO_B2_Rtn | 36
UserIO_B3_Rtn | 37
UserIO_B4_Rtn | 38
UserIO_B5_Rtn | 39
UserIO_B6_Rtn | 40
UserIO_B7_Rtn | 41
UserIO_C0_Rtn | 42
UserIO_C1_Rtn | 43
UserIO_C2_Rtn | 44
UserIO_C3_Rtn | 45
UserIO_C4_Rtn | 46
UserIO_C5_Rtn | 47
UserIO_C6_Rtn | 48
UserIO_C7_Rtn | 49
Gnd | 50

Cable Accessory

MEI offers the following cable accessory: C001-0018


Software FAQs

.

Software FAQs

- What is the MPI?

- Why was the MPI developed?

- What are the prerequisites for learning the MPI?

- What is the difference between 'mpi' and 'mei' data types and methods?

- What is the MPX?

- What is the difference between the MPI and MPX in terms of functionality, authoring code, etc.?

- Should I use the MPI or the MPX to author code?

- How can I perform a silent installation of MEI software (MDK) in a user defined directory?

- How can I verify that MEI software (MDK) has already been installed?

- What is the difference between a node and a motion block on a SynqNet Motion Network?

- Should I save application-specific parameters to firmware?

What is the MPI?

The Motion Programming Interface (MPI) defines a set of object-oriented, C-language functions and data types that you can use to develop motion control applications. The MPI is designed to be independent of the motion controller hardware used, as well as the platform (operating system & compiler) on which the motion control application is built.

To support the MPI, a platform must be 32-bit (e.g. Windows NT). Most 32-bit platforms are capable of multi-threading and multi-tasking, and the MPI has built-in features that simplify the design and development of these types of applications.

Why was the MPI developed?

The MPI is a C language, object-oriented interface that makes it easy to develop motion control applications that run on different types of platforms. Programs written using the MPI range from simple, single-task, single-controller applications to complex multi-task applications that use mutiple motion controllers. The MPI hides platform-specific and firmware implementation details while providing a rich set of functions to control motion at any desired level.

What are the prerequisites for learning the MPI?

You do not need to be a master programmer, but you do need a solid foundation in C. The XMP is a C-programmable motion controller that uses object-oriented programming. Familiarity with C will allow you to quickly attack potentially complex implementation issues. Some familiarity with the basic concepts of motion control is required to understand how to use the sample applications. With no concept of motion control, it is dificult to know what parameters to set to make a motion.

What is the difference between 'mpi' and 'mei' data types and methods?

The purpose of the MPI/MEI prefixes was to prevent any possible conflict with any symbols already defined in the supported operating systems and in C-language and third-party libraries.

  • MPI/MEI - data symbol (data type)
  • mpi/mei - code symbol (method)

The “MEI/mei” prefix denotes additions or extensions to the MPI that usually pertain to the XMP. For example, the MEIAxisConfig{} data structure contains XMP-specific axis configuration parameters that extend the MPI-defined axis configuration parameters (beyond what is already defined in MPIAxisConfig).

Earlier versions of the MPI classified objects or features as generic (MPI) or target-specific (MEI). Generic features were supposed to apply to any motion control design, while target-specific features were only applicable to the XMP. This differentiation has been abandoned for the most part, but backward compatibility has caused some separation of these features to remain. MPI data descriptions are contained in header files in the MPI/include directory while MEI data descriptions are in XMP/include. The documentation emphasizes the type (MPI or MEI) for each feature.

What is the MPX?

The MPX is an ActiveX API (application programming interface) to MPI-compatible controllers (currently only the XMP family). It is an alternative way of writing code for users who do not want to write C code using the standard MPI libraries.

What is the difference between the MPI and MPX in terms of functionality, authoring code, etc.?

The MPI can only be used by C and C++ compilers while the MPX can be used by any language that supports ActiveX controls -- including scripting languages.

The MPX only runs on Windows while the MPI can be used on many more operating systems.

The MPX is easier to use for most tasks, but for complicated tasks it can be more difficult to use, in which case it is better to use the MPI.

The MPX is programmed using the MPI, so everything that is possible with the MPX is possible with the MPI.

Should I use the MPI or the MPX to author code?

The MPX is easier to use for most tasks. There are some tasks that the MPX does not currently support where the MPI would need to be used. Typically, you should program using the MPI if one of the following is true:

  • If the MPX does not provide the functionality you need
  • If the overhead of running an ActiveX control is unacceptable
  • If you are programming on a platform other than Windows

Otherwise, you can program using the MPX.

How can I perform a silent installation of MEI software (MDK) in a user defined directory?

In the command line prompt, type the following:

Win32Setup /v"/qn INSTALLDIR=\"C:\Program Files\Mei\" INSTALLLEVEL=32767" /s

How can I verify that MEI software (MDK) has already been installed?

Check the Winnt\System32 directory to see if the mpivc*.dll file exists. We currently use the mpivc40.dll, mpivc60.dll, and mpivc60d.dll, depending on the version of software installed.. When the MEI software is uninstalled, the MPI *.dll is removed.

What is the difference between a node and motion block on a SynqNet Motion Network?

A node is a place on a network where something happens. For example, CAN is an I/O network that connects I/O nodes (places to hook up digital or analog inputs and outputs).

A motion block refers to a node on a SynqNet Motion Network that is related to motion. A motion block has connections for motors, encoders, I/O, etc.

Should I save application-specific parameters to firmware?

Though this is possible and while it may simplify software design, it can become problematic from a business standpoint in the future. There are three ways to implement application-specific parameters within your application:

Save these parameters to firmware.

  • Potential Obstacle: Parameters for machines may need to change. Your customers may demand that firmware must not change. Also, you may have to fill out a lot of paper work or go through a lot of red tape in order to implement such changes.

  • Potential Obstacle: You decide to upgrade to a new version of the MPI and firmware. Then you will have to load the application-specific parameters into the firmware with Motion Console or config.exe.

Hard code these parameters into your application code.

  • Potential Obstacle: Parameters for machines may need to change--especially if you are designing one piece of software intended to work with multiple machines. Though you don't have to change the firmware, you will need to change your application's code and possibly send customers a new copy of your application.

  • Problem Solved: You no longer have to worry about loading the application-specific parameters into new versions of firmware.

Have your application load these parameters from a configuration file.

  • Potential Obstacle: More effort needed in software design.

  • Problem Solved: You can send customers new parameters without having to change the firmware or your application.

  • Problem Solved: You no longer have to worry about loading the application-specific parameters into new versions of firmware.

At MEI, we strongly encourage the last approach. Please feel free to talk to one of our applications engineers if you have any further questions.


Quick-Link Pinouts

Quick-Links to Connector Pinouts

SynqNet-XMP
Controller I/O
HD15
Micro-D
RJ-45
Backplane Bus Interface
CAN
Rear I/O Bus

RMB-10V
Motor I/O
Power
RJ-45

Analog-XMP
 PCI Bus
CPCI-3U Bus
CPCI-6U Bus
PMC Bus

PCI Main I/O
PCI Expansion I/O
CPCI-3U I/O
CPCI-6U Main, Front I/O
CPCI-6U Expansion, Front I/O
CPCI-6U Main, Rear I/O
CPCI-6U Expansion, Rear I/O
DSP
 CPCI
LC
PCX
STD
LC
PCX
104X